Search

Wednesday, February 20, 2019

Retro-Networking: Cisco Router GRE Tunnels for transporting DECnet over IP using dynamips 7204VXR

Supratim Sanyal's Blog: DECnet GRE Tunneling Cisco Router


The wonderful dynamips emulator along with it's front-end dynagen allows us to relive the excitement of connecting remote machines speaking Digital Equipment Corporation's DECnet networking protocol over the internet using Generic Routing Encapsulation (GRE) and Multipoint Generic Routing Encapsulation (mGRE) tunnels.

I recently deployed a few dynamips-emulated instances of Cisco's venerable 7204VXR router and set up GRE and mGRE tunnels between them to route DECnet and AppleTalk as their passengers. This is a description of how I went about setting up one of those Cisco 7204VXR routers, and configured it as a GRE tunnel end-point. These routers implement the IP (internet protocol), DECnet and classic AppleTalk (Phase-1 and Phase-2) natively, and are a logical extension of my experiments with various classic computers and networking protocols collectively referred to as SANYALnet Labs.

At the time of writing, I have a GRE tunnel from my home to a VPS in Canada, and a second GRE tunnel from my home to a HECnet area router in Perth, Australia. The setup described in this post was performed on the VPS in Canada, running Ubuntu 14.04 LTS.

Not being a great GUI fan, I prefer the Cisco IOS (Internetwork Operating System) command line over graphical tools like GNS3.

Preparing Ubuntu Linux & UFW Firewall for GRE Protocol Support

Ubuntu Packages


Some of the packages I remember installing are dynamips, dynagen, bridge-utils, uml-utilities, ipcalc, vde2, wireshark, tshark.

Enable kernel support for GRE

Generic Routing Encapsulation (GRE) uses IANA-registered IP Protocol 47.  (A surprisingly large number of people confuse GRE/IP Protocol 47 withTCP/IP or UDP/IP Port 47.)

Since Microsoft's "PPTP" VPN implementation also uses GRE and is infamously insecure (no fault of GRE!), Ubuntu does not ship with support for GRE enabled. However, at least on Ubuntu 14.04, enabling GRE support is trivial. To load in GRE protocol support into the kernel, activate the nf_conntrack_pptp module using

# modprobe nf_conntrack_pptp

To load the module automatically at boot time, edit /etc/modules and add the line

nf_conntrack_pptp

To check the module is active:

$ lsmod | egrep "pptp|gre"

which should produce something like:

nf_conntrack_pptp      20480  0
nf_conntrack_proto_gre    16384  1 nf_conntrack_pptp
nf_conntrack          102400  6 nf_conntrack_proto_gre,nf_nat,nf_nat_ipv4,nf_nat_masquerade_ipv4,nf_conntrack_ipv4,nf_conntrack_pptp


Prep UFW Firewall for GRE

First follow these instructions to enable IP forwarding and ACCEPT rules in UFW. In effect, this boils down to:

1) Edit /etc/default/ufw and change the parameter:
    DEFAULT_FORWARD_POLICY="ACCEPT"

2) Edit /etc/ufw/sysctl.conf and enable by uncommenting:
    net.ipv4.ip_forward=1

Now we can add NAT rules for GRE tunnel and IP address forwarding to UFW firewall. Edit the file /etc/ufw/before.rules and add this at the very top:

*nat
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]

# GRE Tunnel protocol to CISCO Router
-A PREROUTING -i br-ip -p gre -j DNAT --to-destination 10.42.2.204
-A POSTROUTING -s 10.42.2.0/24 -o br-ip -j MASQUERADE

COMMIT


Reload UFW, or preferably, reboot.

Bridge, Tap and VDE setup

All of my Linux virtualization hosts are configured with the primary network adapter bridged to a local bridge into which I bridge in tap adapters and VDE switch plugs to support multiple virtual guests. This is important here because when we set up the NAT rules next, we will be using the bridge interface to NAT the dynamips Cisco router on the Linux host. Here is the script that sets up the bridge, tap and VDE:

#!/bin/bash
#
# ---
# bridge-tap-vde-setup.sh
# ---
# Bridge, VDE and Tun/Tap Network Device Setup Script to run emulators.
# Tested on Raspberry Pi Raspbian GNU/Linux 9 armv7l / 4.14.79-v7+
#
# Basically does this:
#
#   -------
#  |Network|
#  |Adapter|
#  |eth0   |
#   -------
#      |           ------
#       ----------|bridge|
#                 |br-ip |
#                  ------
#                    |         --------
#                    |--------|inettap0| <--> For use by TBD emulator
#                    |         --------
#                    |
#                    |         ----------
#                     --------|VDE Switch| (Virtual Distributed Ethernet switch)
#                              ----------
#                              |
#                              |  -----------
#                              |-|vde-ip-tap0| <--> Available to more TBD emulators
#                              |  -----------
#                              |
#                              |  -----------
#                              |-|vde-ip-tap1| <--> Available to more TBD emulators
#                              |  -----------
#
# More details:
# http://supratim-sanyal.blogspot.com/2018/10/bionic-beaver-on-zarchitecture-my.html
#
# Licensed under "THE BEER-WARE LICENSE" (Revision 42):
# Supratim Sanyal <https://goo.gl/FqzyBW> wrote this file. As long as
# you retain this notice you can do whatever you want with this stuff.
# If we meet some day, and you think this stuff is worth it, you can buy
# me a beer in return.
# ---

# ---
# Raspbian specific; dhcpcd is disabled as it was getting IP addresses for all taps and vdeplugs
# ---

# ----
# The physical interface that has the IP address which will be moved to a bridge and
# TAP and VDE plug interfaces made available from the bridge
# ----
DEVICE="eth0"

# ----
# No more changes should be required from here
# ----

HOSTIPANDMASK=`ip addr show dev $DEVICE | grep inet | head -1 | cut -f 6 -d " "`
HOSTIP=`echo $HOSTIPANDMASK|cut -f 1 -d "/"`
HOSTNETMASK=`echo $HOSTIPANDMASK|cut -f 2 -d "/"`
HOSTBCASTADDR=`ip addr show dev $DEVICE | grep inet | head -1 | cut -f 8 -d " "`
HOSTDEFAULTGATEWAY=`route -n | grep ^0.0.0.0 | gawk -- '{ print $2 }'`
NETWORK=`ipcalc $HOSTIP/$HOSTNETMASK | grep Network | cut -f 2 -d ":" | cut -f 1 -d "/" | tr -d '[:space:]'`

echo `date` ---- GATHERED INFORMATION -----
echo `date` HOSTIP=$HOSTIP HOSTNETMASK=$HOSTNETMASK NETWORK=$NETWORK HOSTBCASTADDR=$HOSTBCASTADDR HOSTDEFAULTGATEWAY=$HOSTDEFAULTGATEWAY
echo `date` -------------------------------

# ---
# Create a TAP network interface for emulators
# ---
ip tuntap add inettap0 mode tap user localuser

# ---
# Also create a VDE switch with TAP plugs for use by simuators
# ---

#
vde_switch -t vde-ip-tap0 -s /tmp/vde-ip.ctl -m 666 --mgmt /tmp/vde-ip.mgmt --mgmtmode 666 --daemon # spare plug
vde_plug2tap -s /tmp/vde-ip.ctl -m 666 -d vde-ip-tap1  # spare plug
#vde_plug2tap -s /tmp/vde-ip.ctl -m 666 -d vde-ip-tap2  # spare plug
#vde_plug2tap -s /tmp/vde-ip.ctl -m 666 -d vde-ip-tap3  # spare plug

# Create a Bridge
ip link add name br-ip type bridge
brctl stp br-ip on

# Bridge the NIC $DEVICE, the TAP device and VDE Switch TAP0 plug
ip link set $DEVICE master br-ip
ip link set inettap0 master br-ip
ip link set vde-ip-tap0 master br-ip

# Remove default route and move the IP address from $DEVICE to the bridge
ip route delete default via $HOSTDEFAULTGATEWAY dev $DEVICE
ip addr flush dev $DEVICE
ip addr add $HOSTIPANDMASK broadcast $HOSTBCASTADDR dev br-ip

# Bring everything back up
ip link set dev br-ip up
ip link set dev inettap0 up
ip link set vde-ip-tap0 up
ip link set vde-ip-tap1 up
#ip link set vde-ip-tap2 up
#ip link set vde-ip-tap3 up

# Reset the default route via the bridge interface which now has the IP
ip route add default via $HOSTDEFAULTGATEWAY dev br-ip

#echo `date` ---- NETWORK RECONFIGURED, WAITING TO SETTLE DOWN ----
#sleep 30

echo `date` ---- RELOADING UFW ----
ufw reload
sync

echo `date` ---- AFTER BRIDGE AND TAP ----
ip addr
echo `date` --- ROUTE ---
#ip route show
route -n
echo `date` --- BRIDGE ---
brctl show
#echo `date` --- IPTABLES ---
#iptables -L
echo `date` --- UFW ---
ufw status verbose
#echo `date` --- PING TEST ---
#ping -c 5 google.com
echo `date` -------------------------------

# --
# We can now attach simulators
# --
sync

Setting up the Local TAP Adapters

In addition, I created two local tap adapters for the Cisco router's NAT'd IP and standalone DECnet interfaces. The DECnet tap does not need to be connected to anything other than the Cisco router since DECnet will be tunneled over GRE using the NAT'd IP tap. Here is the script that sets up the local tap adapters and enables kernel IP forwarding. This is executed from /etc/rc.local right after the bridge/tap/VDE script above.

#!/bin/bash
# Sets up local taps

echo 1 > /proc/sys/net/ipv4/ip_forward

ip tuntap add ciscotap0 mode tap user localuser # DECnet -> CISCO f0/0
ip tuntap add ciscotap1 mode tap user localuser # IP -> CISCO f0/1
ifconfig ciscotap0 up
ifconfig ciscotap1 10.42.2.1 netmask 255.255.255.0 up

ufw reload

With the network configuration in place, we can assign a local IP 10.42.2.204 to our dynamips Cisco router and have the NAT iptables rules in UFW "before" configuration forward GRE packets to the Cisco router. Here is a summary of the network setup after a fresh reboot.

# ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         LIMIT       Anywhere


# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br-ip state UP group default qlen 1000
    link/ether 00:50:56:95:11:b8 brd ff:ff:ff:ff:ff:ff
3: inettap0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast master br-ip state DOWN group default qlen 1000
    link/ether 06:de:f9:f7:7e:4d brd ff:ff:ff:ff:ff:ff
4: vde-ip-tap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br-ip state UNKNOWN group default qlen 1000
    link/ether 5a:4b:b5:0f:a2:2d brd ff:ff:ff:ff:ff:ff
5: vde-ip-tap1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 56:49:97:fa:43:d2 brd ff:ff:ff:ff:ff:ff
6: br-ip: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:50:56:95:11:b8 brd ff:ff:ff:ff:ff:ff
    inet 64.137.160.124/24 brd 64.137.160.255 scope global br-ip
       valid_lft forever preferred_lft forever
7: ciscotap0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 26:bd:89:90:ca:ce brd ff:ff:ff:ff:ff:ff
8: ciscotap1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether ca:48:59:de:f0:9e brd ff:ff:ff:ff:ff:ff
    inet 10.42.2.1/24 brd 10.42.2.255 scope global ciscotap1
       valid_lft forever preferred_lft forever


route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         route.cloudatco 0.0.0.0         UG    0      0        0 br-ip
10.42.2.0       *               255.255.255.0   U     0      0        0 ciscotap1
64.137.160.0    *               255.255.255.0   U     0      0        0 br-ip

ip route show
default via 64.137.160.1 dev br-ip 
10.42.2.0/24 dev ciscotap1  proto kernel  scope link  src 10.42.2.1 

64.137.160.0/24 dev br-ip  proto kernel  scope link  src 64.137.160.124 

# iptables -t nat -L
Chain PREROUTING (policy ACCEPT)
target     prot opt source               destination         
DNAT       gre  --  anywhere             anywhere             to:10.42.2.204

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination         
MASQUERADE  all  --  10.42.2.0/24         anywhere            


Setting up dynamips Cisco 7206VXR Routers for DECnet over GRE Tunnel

Router at Tunnel Endpoint

This is a description of one of the GRE tunnel end-points. The other GRE tunnel end-points are configured similarly, with obvious differences in destination IP addresses and their own DECnet and IP addresses etc.

Dynagen Configuration (vps4-cisco-7200.ini)

[localhost]
    workingdir = /home/localuser/cisco-router/dynagen_data
    model = 7200
    ghostios = true
    sparsemem = true
    [[7200]]
        image = /home/localuser/cisco-router/images/c7200-jk9o3s-mz.123-15.image
        npe = npe-400
        ram = 160
        idlepc = 0x60743ee8
    [[ROUTER R1]]
        s1/0 = R2 s1/0
#        f0/0 = NIO_linux_eth:vde-dnet-tap0
        f0/0 = NIO_tap:ciscotap0
#        f0/1 = NIO_linux_eth:inettap0
#        f0/1 = NIO_tap:inettap0
        f0/1 = NIO_tap:ciscotap1
    [[ROUTER R2]]


Startup Scripts

Both dynamips and dynagen run in virtual screen sessions using the "screen" ultility. Here are the two startup scripts.

# ----------run-dynamips-in-screen.sh 
#!/bin/bash

if /bin/pidof -x "dynamips" >/dev/null; then
logger "$0: dynamips already running, check screen -r cisco-router"
echo "$0: dynamips already running, check screen -r cisco-router"
        echo "screens:"
        /usr/bin/screen -ls
        exit 0
fi

cd ~/cisco-router/dynamips_data
#ifconfig vde-dnet-tap0 up
screen -S cisco-router -m -d nice -n 6 ionice -c2 dynamips -H 7200

sleep 2
screen -ls



# ---------- run-dynagen-in-screen.sh 
#!/bin/bash

if /bin/pidof -x "dynagen" >/dev/null; then
logger "$0: dynagen already running, check screen -r cisco-console"
echo "$0: dynagen already running, check screen -r cisco-console"
        echo "screens:"
        /usr/bin/screen -ls
        exit 0
fi

cd ~/cisco-router/
echo \"list\" to see list of routers
echo \"console R1\" to start xterm console to R1 router
echo OR telnet 10.42.2.204 OR telnet localhost 2000
echo \"start/all\" and \"stop/all\" to start and stop routers
echo \"exit\" also shuts down the routers but does not kill the emulator
echo \"screen -r cisco-router\" and ^C kills the dynamips emulator
screen -S cisco-console -m -d nice -n 6 ionice -c2 dynagen vps4-cisco-7200.ini

sleep 2
screen -ls


Router Configuration (show run)

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO-VPS4
!
boot-start-marker
boot-end-marker
!
enable secret 5 longgarbledstring
enable password redacted
!
no aaa new-model
ip subnet-zero
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
ip cef
ip audit po max-events 100
appletalk routing
!
decnet routing 1.919
decnet node-type routing-iv
!
!
!
!
!
!
!
!
!         
!
!
!
!
!

!
!
!
!
interface Tunnel1
 no ip address
 ip mtu 1400
 ip tcp adjust-mss 1360
 decnet cost 8
 decnet hello-timer 3
 decnet routing-timer 5
 tunnel source FastEthernet0/1
 tunnel destination 71.114.22.90
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 appletalk cable-range 10422-10422 10422.205
 appletalk zone SANYALnet
 decnet cost 8
 decnet hello-timer 2
 decnet routing-timer 4
!
interface FastEthernet0/1
 ip address 10.42.2.204 255.0.0.0
 ip broadcast-address 10.255.255.255
 duplex half
 speed auto
 no mop enabled
!         
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/4
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/5
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/6
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/7
 no ip address
 shutdown
 serial restart-delay 0
!
ip default-gateway 10.42.2.1
ip classless
ip default-network 10.0.0.0
ip route 0.0.0.0 0.0.0.0 10.42.2.1
no ip http server
no ip http secure-server
!
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
appletalk local-routing
decnet host MIM 1.13
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password redacted
 login
!
!
end


Router interfaces

$ telnet 10.42.2.204
Trying 10.42.2.204...
Connected to 10.42.2.204.
Escape character is '^]'.


User Access Verification

Password: 
CISCO-VPS4>enable
Password: 
CISCO-VPS4#show int
FastEthernet0/0 is up, line protocol is up 
  Hardware is i82543 (Livengood), address is aa00.0400.9707 (bia ca00.0b2d.0008)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 1 packets/sec
     0 packets input, 0 bytes
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1382 packets output, 89826 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up 
  Hardware is i82543 (Livengood), address is ca00.0b2d.0006 (bia ca00.0b2d.0006)
  Internet address is 10.42.2.204/8
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 4000 bits/sec, 3 packets/sec
  5 minute output rate 5000 bits/sec, 3 packets/sec
     1200 packets input, 449672 bytes
     Received 5 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1335 packets output, 754793 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial1/0 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input 00:18:48, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 404 bytes, 0 no buffer
     Received 4 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial1/1 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/2 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/3 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/4 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/5 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/6 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Serial1/7 is administratively down, line protocol is down 
  Hardware is M8T-X.21
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

Tunnel1 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 170/255, rxload 85/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.42.2.204 (FastEthernet0/1), destination 71.114.22.90
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets disabled,  fast tunneling enabled
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 3000 bits/sec, 1 packets/sec
  5 minute output rate 6000 bits/sec, 1 packets/sec
     871 packets input, 452898 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     949 packets output, 705533 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

CISCO-VPS4#show ip inter  
FastEthernet0/0 is up, line protocol is up
  Internet protocol processing disabled
FastEthernet0/1 is up, line protocol is up
  Internet address is 10.42.2.204/8
  Broadcast address is 10.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Feature Fast switching turbo vector
  IP Feature CEF switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
Serial1/0 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/1 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/2 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/3 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/4 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/5 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/6 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/7 is administratively down, line protocol is down
  Internet protocol processing disabled
Tunnel1 is up, line protocol is up

  Internet protocol processing disabled

CISCO-VPS4#show appletalk int
FastEthernet0/0 is up, line protocol is up
  AppleTalk cable range is 10422-10422
  AppleTalk address is 10422.205, Valid
  AppleTalk zone is "SANYALnet"
  AppleTalk address gleaning is disabled
  AppleTalk route cache is enabled
FastEthernet0/1 is up, line protocol is up
  AppleTalk protocol processing disabled
Serial1/0 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/1 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/2 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/3 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/4 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/5 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/6 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Serial1/7 is administratively down, line protocol is down
  AppleTalk protocol processing disabled
Tunnel1 is up, line protocol is up

  AppleTalk protocol processing disabled

CISCO-VPS4#show decnet int
Global DECnet parameters for network 0:
  Local address is 1.919, node type is routing-iv
  Nearest Level-2 router is  1.579
  Maximum node is 1023, maximum area is 63, maximum visits is 63
  Maximum paths is 1, path split mode is normal 
  Local maximum cost is 1022, maximum hops is 30
  Area maximum cost is 1022, maximum hops is 30
  Static routes *NOT* being sent in routing updates
  Cluster-alias routes *NOT* being sent in routing updates
FastEthernet0/0 is up, line protocol is up, encapsulation is ARPA
  Interface cost is 8, priority is 64, DECnet network: 0
  We are the designated router
  Sending HELLOs every 2 seconds, routing updates 4 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 0
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0
  Number of PhaseIV+ router adjacencies is : 0
FastEthernet0/1 is up, line protocol is up, encapsulation is ARPA
  DECnet protocol processing not enabled
Serial1/0 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/1 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/2 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/3 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/4 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/5 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/6 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/7 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Tunnel1 is up, line protocol is up, encapsulation is TUNNEL
  Interface cost is 8, priority is 64, DECnet network: 0
  The designated router is 1.579
  Sending HELLOs every 3 seconds, routing updates 5 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 1
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0

  Number of PhaseIV+ router adjacencies is : 1


DECnet Route and Neighbors

CISCO-VPS4#show decnet route
  Node       Cost  Hops           Next Hop to Node       Expires  Prio
*(Area)        8     1             Tunnel1 -> 1.579  
*MIM          11     3             Tunnel1 -> 1.579  
*1.15         14     4             Tunnel1 -> 1.579  
*1.21         14     4             Tunnel1 -> 1.579  
*1.152        14     4             Tunnel1 -> 1.579  
*1.250        14     4             Tunnel1 -> 1.579  
*1.253        14     4             Tunnel1 -> 1.579  
*1.301        14     4             Tunnel1 -> 1.579  
*1.550        10     2             Tunnel1 -> 1.579  
*1.551        10     2             Tunnel1 -> 1.579  
*1.552        10     2             Tunnel1 -> 1.579  
*1.553        10     2             Tunnel1 -> 1.579  
*1.554        10     2             Tunnel1 -> 1.579  
*1.555        10     2             Tunnel1 -> 1.579  
*1.556        10     2             Tunnel1 -> 1.579  
*1.557        10     2             Tunnel1 -> 1.579  
*1.558        10     2             Tunnel1 -> 1.579  
*1.559        10     2             Tunnel1 -> 1.579  
*1.570        10     2             Tunnel1 -> 1.579  
*1.571        10     2             Tunnel1 -> 1.579  
*1.572        10     2             Tunnel1 -> 1.579  
*1.573        10     2             Tunnel1 -> 1.579  
*1.578        11     3             Tunnel1 -> 1.579  
*1.579         8     1             Tunnel1 -> 1.579          5     64  V+
*1.601        18     5             Tunnel1 -> 1.579  
*1.602        15     4             Tunnel1 -> 1.579  
*1.605        18     5             Tunnel1 -> 1.579  
*1.610        18     5             Tunnel1 -> 1.579  
*1.620        18     5             Tunnel1 -> 1.579  
*1.740        14     4             Tunnel1 -> 1.579  
*1.742        14     4             Tunnel1 -> 1.579  
*1.747        14     4             Tunnel1 -> 1.579  
*1.748        14     4             Tunnel1 -> 1.579  
*1.750        11     3             Tunnel1 -> 1.579  
*1.770        14     4             Tunnel1 -> 1.579  
*1.771        14     4             Tunnel1 -> 1.579  
*1.790        10     2             Tunnel1 -> 1.579  
*1.791        10     2             Tunnel1 -> 1.579  
*1.794        10     2             Tunnel1 -> 1.579  
*1.915        10     2             Tunnel1 -> 1.579  
*1.919         0     0             (Local) -> 1.919

CISCO-VPS4#show decnet neigh
Net Node     Interface            MAC address    Flags
0   1.579    Tunnel1              0000.0000.0000 V 


And finally, here is a section of tshark showing the traffic on the tap adapter that the Cisco router is connected to:

$ tshark -i ciscotap1
Capturing on 'ciscotap1'
    1 0.000000000  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
    2 0.010244129  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
    3 1.255455372 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
    4 1.255474067 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
    5 1.980104275  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
    6 4.305465162 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
    7 4.305927990 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
    8 4.992895607  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
    9 5.003158079  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   10 5.013470766  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   11 5.024216726  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   12 5.680566436 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   13 5.680590979 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   14 7.998893518  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   15 8.998245661 ca:00:0b:2d:00:06 → ca:00:0b:2d:00:06 LOOP 60 Reply
   16 10.009636083  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   17 10.019839161  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   18 10.070231673 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   19 10.070252853 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   20 10.988181697  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   21 11.553758599 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   22 11.553794355 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   23 11.553835386 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   24 13.996455811  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   25 14.562071262 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   26 14.562090999 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   27 15.010424154  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   28 15.020705509  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   29 15.030982401  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   30 17.001990425  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   31 18.995731534 ca:00:0b:2d:00:06 → ca:00:0b:2d:00:06 LOOP 60 Reply
   32 19.019175742 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   33 19.019194256 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   34 19.019201092 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   35 19.019207379 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   36 19.992366335  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   37 20.008291743  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   38 20.018516284  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   39 22.997585210  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   40 23.627106890 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   41 23.627125349 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   42 24.026321306 ca:48:59:de:f0:9e → ca:00:0b:2d:00:06 ARP 42 Who has 10.42.2.204? Tell 10.42.2.1
   43 24.030500265 ca:00:0b:2d:00:06 → ca:48:59:de:f0:9e ARP 60 10.42.2.204 is at ca:00:0b:2d:00:06
   44 25.009808182  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   45 25.021018991  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   46 25.032683341  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   47 26.008328765  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   48 26.543406661 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   49 26.543560700 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   50 27.982440383 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   51 27.982462059 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   52 29.002420586  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   53 29.012671361 ca:00:0b:2d:00:06 → ca:00:0b:2d:00:06 LOOP 60 Reply
   54 29.995583950  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   55 30.008222753  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   56 31.983114902  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   57 32.414551636 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   58 32.414568952 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   59 33.943888516 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   60 33.943910935 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   61 33.943923202 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   62 35.001442315  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   63 35.011641874  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   64 35.021859556  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   65 35.033380852  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   66 36.954632224 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   67 36.954649859 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   68 38.000891414  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   69 39.019368280 ca:00:0b:2d:00:06 → ca:00:0b:2d:00:06 LOOP 60 Reply
   70 39.993480364  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   71 40.003707088  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   72 40.992456396  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   73 41.465544624 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   74 41.465563272 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   75 41.465573218 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   76 41.465580377 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   77 43.999177660  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   78 44.989366697  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   79 44.999788934  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   80 45.010053625  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   81 45.937675757 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   82 45.937696001 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   83 47.003696897  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   84 48.850238460 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
   85 48.850258954 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
   86 49.021398435 ca:00:0b:2d:00:06 → ca:00:0b:2d:00:06 LOOP 60 Reply
   87 49.997432676 ca:00:0b:2d:00:06 → CDP/VTP/DTP/PAgP/UDLD CDP 376 Device ID: CISCO-VPS4  Port ID: FastEthernet0/1  
   88 50.008011229  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   89 50.018237231  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
   90 50.028407881  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   91 50.137707070 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   92 50.137725521 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   93 50.938322858 ca:48:59:de:f0:9e → ca:00:0b:2d:00:06 ARP 42 Who has 10.42.2.204? Tell 10.42.2.1
   94 50.940299813 ca:00:0b:2d:00:06 → ca:48:59:de:f0:9e ARP 60 10.42.2.204 is at ca:00:0b:2d:00:06
   95 53.007707715  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
   96 54.681849425 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   97 54.681875191 71.114.22.90 → 10.42.2.204  GRE 74 Encapsulated 0x6003 (unknown)
   98 55.005911408  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
   99 55.016207497  10.42.2.204 → 71.114.22.90 GRE 794 Encapsulated 0x6003 (unknown)
  100 55.026565784  10.42.2.204 → 71.114.22.90 GRE 1474 Encapsulated 0x6003 (unknown)
  101 55.990359246  10.42.2.204 → 71.114.22.90 GRE 74 Encapsulated 0x6003 (unknown)
  102 56.066812388 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
  103 56.066833226 71.114.22.90 → 10.42.2.204  GRE 794 Encapsulated 0x6003 (unknown)
  104 56.066839699 71.114.22.90 → 10.42.2.204  GRE 1474 Encapsulated 0x6003 (unknown)
^C104 packets captured

CISCO GRE DECNet TUNNEL: A COMPLETE EXAMPLE

Here is another complete example of setting up a DECnet GRE tunnel between two Cisco routers. In this example, the local router at which we are executing the following commands has a NAT IP address of 10.42.2.204, and is NAT'd behind a Internet-facing gateway. The local DECnet address is 1.910, and the remote DECnet address is 1.919. We setup "tunnel0" to the remote router visible over the internet at 45.62.248.66. We can then successfully communicate with 1.919 over DECnet tunneled over GRE.

FastEthernet0/0 is connected to the DECnet-only network. FastEthernet0/1 is connected to the internet via the NAT host. DECnet and internet access are already verified to be working before configuring this tunnel.

Both are dynamips-emulated routers residing inside Ubuntu linux servers which have been configured to support GRE and NAT forwarding as described above.

In addition, we configure the NTP server on this router to keep and serve accurate time before exiting.


$ telnet 10.42.2.204
Trying 10.42.2.204...
Connected to 10.42.2.204.
Escape character is '^]'.


User Access Verification

Password: 
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>en
Password: 
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#config term
Enter configuration commands, one per line.  End with CNTL/Z.
CISCO-VPS4(config)#
CISCO-VPS4(config)#
CISCO-VPS4(config)#interface tunnel0
CISCO-VPS4(config-if)#description GRE tunnel for testing and experimentation
CISCO-VPS4(config-if)#no ip address
CISCO-VPS4(config-if)#logging event subif-link-status
CISCO-VPS4(config-if)#decnet cost 20
CISCO-VPS4(config-if)#decnet routing-timer 5
CISCO-VPS4(config-if)#decnet hello-timer 3
CISCO-VPS4(config-if)#tunnel source f0/1
CISCO-VPS4(config-if)#tunnel destination 45.62.248.66 !Cloud VPS 3
CISCO-VPS4(config-if)#tunnel path-mtu-discovery
CISCO-VPS4(config-if)#
CISCO-VPS4(config-if)#end
CISCO-VPS4#
CISCO-VPS4#write mem
Building configuration...
[OK]
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show int tunnel0
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  Description: GRE tunnel for testing and experimentation
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.42.2.204 (FastEthernet0/1), destination 45.62.248.66
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets disabled,  fast tunneling enabled
  Path MTU Discovery, ager 10 mins, min MTU 92, MTU 0, expires never
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     15 packets output, 795 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show decnet
Global DECnet parameters for network 0:
  Local address is 1.910, node type is routing-iv
  Nearest Level-2 router is  NONE
  Maximum node is 1023, maximum area is 63, maximum visits is 63
  Maximum paths is 1, path split mode is normal 
  Local maximum cost is 1022, maximum hops is 30
  Area maximum cost is 1022, maximum hops is 30
  Static routes *NOT* being sent in routing updates
  Cluster-alias routes *NOT* being sent in routing updates
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show ip
% Incomplete command.

CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show ip int
FastEthernet0/0 is up, line protocol is up
  Internet protocol processing disabled
FastEthernet0/1 is up, line protocol is up
  Internet address is 10.42.2.204/8
  Broadcast address is 10.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Feature Fast switching turbo vector
  IP Feature CEF switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
Serial1/0 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/1 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/2 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/3 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/4 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/5 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/6 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/7 is administratively down, line protocol is down
  Internet protocol processing disabled
Tunnel0 is up, line protocol is up
  Internet protocol processing disabled
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show decnet int
Global DECnet parameters for network 0:
  Local address is 1.910, node type is routing-iv
  Nearest Level-2 router is  NONE
  Maximum node is 1023, maximum area is 63, maximum visits is 63
  Maximum paths is 1, path split mode is normal 
  Local maximum cost is 1022, maximum hops is 30
  Area maximum cost is 1022, maximum hops is 30
  Static routes *NOT* being sent in routing updates
  Cluster-alias routes *NOT* being sent in routing updates
FastEthernet0/0 is up, line protocol is up, encapsulation is ARPA
  Interface cost is 20, priority is 64, DECnet network: 0
  We are the designated router
  Sending HELLOs every 2 seconds, routing updates 4 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 0
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0
  Number of PhaseIV+ router adjacencies is : 0
FastEthernet0/1 is up, line protocol is up, encapsulation is ARPA
  DECnet protocol processing not enabled
Serial1/0 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/1 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/2 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/3 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/4 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/5 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/6 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/7 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Tunnel0 is up, line protocol is up, encapsulation is TUNNEL
  Interface cost is 20, priority is 64, DECnet network: 0
  Sending HELLOs every 3 seconds, routing updates 5 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 0
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0
  Number of PhaseIV+ router adjacencies is : 0
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4# ! ---------------
CISCO-VPS4# ! BRINGING THE OTHER TUNNEL END-POINT UP NOW 
CISCO-VPS4# ! ---------------    
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show clock
*18:31:11.671 UTC Wed Feb 20 2019
CISCO-VPS4#
CISCO-VPS4>
CISCO-VPS4>show clock
*18:44:48.515 UTC Wed Feb 20 2019
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>! --
CISCO-VPS4>! TUNNEL ON OTHER SIDE IS NOW CONFIGURED (on VPS 3)
CISCO-VPS4>! --
CISCO-VPS4>
CISCO-VPS4>show int tunnel0
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  Description: GRE tunnel for testing and experimentation
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 141/255, rxload 113/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.42.2.204 (FastEthernet0/1), destination 45.62.248.66
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets disabled,  fast tunneling enabled
  Path MTU Discovery, ager 10 mins, min MTU 92, MTU 0, expires never
  Last input 00:00:00, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 4000 bits/sec, 1 packets/sec
  5 minute output rate 5000 bits/sec, 1 packets/sec
     618 packets input, 317086 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     644 packets output, 338314 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>show ip int 
FastEthernet0/0 is up, line protocol is up
  Internet protocol processing disabled
FastEthernet0/1 is up, line protocol is up
  Internet address is 10.42.2.204/8
  Broadcast address is 10.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Feature Fast switching turbo vector
  IP Feature CEF switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
Serial1/0 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/1 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/2 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/3 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/4 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/5 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/6 is administratively down, line protocol is down
  Internet protocol processing disabled
Serial1/7 is administratively down, line protocol is down
  Internet protocol processing disabled
Tunnel0 is up, line protocol is up
  Internet protocol processing disabled
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>show decnet int
Global DECnet parameters for network 0:
  Local address is 1.910, node type is routing-iv
  Nearest Level-2 router is  1.919
  Maximum node is 1023, maximum area is 63, maximum visits is 63
  Maximum paths is 1, path split mode is normal 
  Local maximum cost is 1022, maximum hops is 30
  Area maximum cost is 1022, maximum hops is 30
  Static routes *NOT* being sent in routing updates
  Cluster-alias routes *NOT* being sent in routing updates
FastEthernet0/0 is up, line protocol is up, encapsulation is ARPA
  Interface cost is 20, priority is 64, DECnet network: 0
  We are the designated router
  Sending HELLOs every 2 seconds, routing updates 4 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 0
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0
  Number of PhaseIV+ router adjacencies is : 0
FastEthernet0/1 is up, line protocol is up, encapsulation is ARPA
  DECnet protocol processing not enabled
Serial1/0 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/1 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/2 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/3 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/4 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/5 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/6 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Serial1/7 is administratively down, line protocol is down, encapsulation is HDLC
  DECnet protocol processing not enabled
Tunnel0 is up, line protocol is up, encapsulation is TUNNEL
  Interface cost is 20, priority is 64, DECnet network: 0
  The designated router is 1.919
  Sending HELLOs every 3 seconds, routing updates 5 seconds
  PhaseIV VAX cluster hold time is 300 seconds
  Smallest router blocksize seen is 1498 bytes
  Routing input list is not set, output list is not set
  Access list is not set
  DECnet fast switching is enabled
  Number of L1 router adjacencies is : 1
  Number of L2 router adjacencies is : 0
  Number of non-PhaseIV+ router adjacencies is : 0
  Number of PhaseIV+ router adjacencies is : 1
CISCO-VPS4>
CISCO-VPS4>! -- ^^^ 1.919 is on the other end of the tunnel (on VPS3) --
CISCO-VPS4>
CISCO-VPS4>show decnet neigh
Net Node     Interface            MAC address    Flags
0   1.919    Tunnel0              0000.0000.0000 V 
CISCO-VPS4>
CISCO-VPS4>! -- ^^^ 1.919 is on the other end of the tunnel (on VPS3) --
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>                                                             
CISCO-VPS4>
CISCO-VPS4>show decnet route
  Node       Cost  Hops           Next Hop to Node       Expires  Prio
*(Area)       20     1             Tunnel0 -> 1.919  
*MIM          41     3             Tunnel0 -> 1.919  
*1.15         44     4             Tunnel0 -> 1.919  
*1.21         44     4             Tunnel0 -> 1.919  
*1.152        44     4             Tunnel0 -> 1.919  
*1.250        44     4             Tunnel0 -> 1.919  
*1.253        44     4             Tunnel0 -> 1.919  
*1.301        44     4             Tunnel0 -> 1.919  
*1.550        40     2             Tunnel0 -> 1.919  
*1.551        40     2             Tunnel0 -> 1.919  
*1.552        40     2             Tunnel0 -> 1.919  
*1.553        40     2             Tunnel0 -> 1.919  
*1.554        40     2             Tunnel0 -> 1.919  
*1.555        40     2             Tunnel0 -> 1.919  
*1.556        40     2             Tunnel0 -> 1.919  
*1.557        40     2             Tunnel0 -> 1.919  
*1.558        40     2             Tunnel0 -> 1.919  
*1.559        40     2             Tunnel0 -> 1.919  
*1.570        40     2             Tunnel0 -> 1.919  
*1.571        40     2             Tunnel0 -> 1.919  
*1.572        40     2             Tunnel0 -> 1.919  
*1.573        40     2             Tunnel0 -> 1.919  
*1.578        41     3             Tunnel0 -> 1.919  
*1.579        40     2             Tunnel0 -> 1.919  
*1.601        48     5             Tunnel0 -> 1.919  
*1.602        45     4             Tunnel0 -> 1.919  
*1.605        48     5             Tunnel0 -> 1.919  
*1.610        48     5             Tunnel0 -> 1.919  
*1.620        48     5             Tunnel0 -> 1.919  
*1.740        44     4             Tunnel0 -> 1.919  
*1.742        44     4             Tunnel0 -> 1.919  
*1.747        44     4             Tunnel0 -> 1.919  
*1.748        44     4             Tunnel0 -> 1.919  
*1.750        41     3             Tunnel0 -> 1.919  
*1.770        44     4             Tunnel0 -> 1.919  
*1.771        44     4             Tunnel0 -> 1.919  
*1.790        40     2             Tunnel0 -> 1.919  
*1.791        40     2             Tunnel0 -> 1.919  
*1.794        40     2             Tunnel0 -> 1.919  
*1.910         0     0             (Local) -> 1.910
*1.915        40     2             Tunnel0 -> 1.919  
*1.919        20     1             Tunnel0 -> 1.919          9     64  V+
CISCO-VPS4>! -- ^^^ 1.919 is on the other end of the tunnel (on VPS3) --
CISCO-VPS4>
CISCO-VPS4>! -- configure NTP --
CISCO-VPS4>
CISCO-VPS4>
CISCO-VPS4>en
Password: 
CISCO-VPS4#config term
Enter configuration commands, one per line.  End with CNTL/Z.
CISCO-VPS4(config)#
CISCO-VPS4(config)#
CISCO-VPS4(config)#ntp master
CISCO-VPS4(config)#ntp server 132.163.97.3
CISCO-VPS4(config)#ntp server 132.163.97.2
CISCO-VPS4(config)#ntp server 132.163.97.4
CISCO-VPS4(config)#ntp server 129.6.15.30
CISCO-VPS4(config)#ntp server 129.6.15.29
CISCO-VPS4(config)#ntp server 129.6.15.27
CISCO-VPS4(config)#
CISCO-VPS4(config)#end
CISCO-VPS4#write mem
Building configuration...
[OK]
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#show ntp status
Clock is synchronized, stratum 2, reference is 132.163.97.2
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18
reference time is E0181FBA.50A7E9C6 (18:49:30.315 UTC Wed Feb 20 2019)
clock offset is 123.4686 msec, root delay is 104.31 msec
root dispersion is 533.52 msec, peer dispersion is 405.08 msec
CISCO-VPS4#
CISCO-VPS4#show ntp assoc

      address         ref clock     st  when  poll reach  delay  offset    disp
 ~132.163.97.3     0.0.0.0          16     -    64    0     0.0    0.00  16000.
-~132.163.97.2     .NIST.            1    18    64  334   104.1  127.96   386.3
+~132.163.97.4     .NIST.            1     6    64  367    64.0  108.58     3.5
 ~127.127.7.1      127.127.7.1       7     4    64  377     0.0    0.00     0.0
-~129.6.15.30      .NIST.            1    18    64   20    60.0  126.04  16000.
*~129.6.15.29      .NIST.            1    12    64  275    36.0  107.80     5.0
+~129.6.15.27      .NIST.            1    13    64  131    56.1  110.82   380.3
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured
CISCO-VPS4#
CISCO-VPS4#
CISCO-VPS4#      
CISCO-VPS4#write mem
Building configuration...
[OK]
CISCO-VPS4#logout
Connection closed by foreign host.

Appendix

The following example output of "SHOW RUN" command on a production router illustrates configured tunnels using GRE and mGRE transporting DECnet and AppleTalk traffic.


!
! Last configuration change at 21:09:01 UTC Thu Oct 28 2021
! NVRAM config last updated at 21:12:14 UTC Thu Oct 28 2021
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO7204VXR_IMPRTR
!
boot-start-marker
boot-end-marker
!
enable secret 5 <redacted>
enable password <redacted>
!
no aaa new-model
!
!
ip cef
ip domain name sanyalnet.lan
ip name-server 208.67.222.222
ip name-server 208.67.220.220
!
!
appletalk routing
!
decnet routing 31.1023
decnet node-type area
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
description DECnet GRE Tunnel to SHAKTI on VPS4
no ip address
logging event subif-link-status
decnet cost 4
decnet hello-timer 3
decnet routing-timer 5
decnet router-priority 10
tunnel source FastEthernet0/1
tunnel destination 142.47.102.100
tunnel path-mtu-discovery
!
interface Tunnel9
no ip address
logging event subif-link-status
decnet cost 9
tunnel source FastEthernet0/1
tunnel destination 50.131.218.138
tunnel path-mtu-discovery
!
interface Tunnel12
description Tunnel to Area 12 A12RTR 12.1023 Tim Sneddon DECrouter 90T2 IOS V10.3 Perth, Western Australia
no ip address
logging event subif-link-status
decnet cost 18
decnet hello-timer 30
tunnel source FastEthernet0/1
tunnel destination 163.47.57.118
tunnel path-mtu-discovery
!
interface Tunnel22
description HECnet tunnel for Mark Darvill (Area 22)
no ip address
logging event subif-link-status
decnet cost 7
tunnel source FastEthernet0/1
tunnel destination 81.138.115.178
tunnel path-mtu-discovery
!
interface Tunnel23
description HECnet tunnel for Mark G Thomas (Area 23) [Version:307]
no ip address
logging event subif-link-status
decnet cost 4
tunnel source FastEthernet0/1
tunnel destination 71.246.8.102
tunnel path-mtu-discovery
!
interface Tunnel27
description Tunnel to Area 27 DECnet/Python Router AREA27 Mark Berryman <mark@theberrymans.com> Brighton, Colorado, USA
no ip address
logging event subif-link-status
decnet cost 5
decnet hello-timer 120
decnet routing-timer 180
tunnel source FastEthernet0/1
tunnel destination 76.25.105.11
tunnel path-mtu-discovery
!
interface Tunnel29
description HECnet tunnel for 29.206 (ONAPI) Wilm Boerhout <wboerhout@gmail.com>
no ip address
logging event subif-link-status
decnet cost 8
decnet hello-timer 5
decnet routing-timer 15
tunnel source FastEthernet0/1
tunnel destination 86.87.9.111
tunnel path-mtu-discovery
!
interface Tunnel34
description Tunnel to Area 34 Tomas Prybil <tomas@prybil.se>
no ip address
logging event subif-link-status
appletalk cable-range 18-18 18.1
appletalk zone foobar
decnet cost 8
decnet routing-timer 30
tunnel source FastEthernet0/1
tunnel destination 81.236.171.34
tunnel path-mtu-discovery
!
interface Tunnel35
description DECnet GRE Tunnel to area 35 "Wiz" David Moylan <djm@wiz.net.au>
no ip address
logging event subif-link-status
decnet cost 14
decnet hello-timer 90
decnet routing-timer 120
tunnel source FastEthernet0/1
tunnel destination 203.30.197.254
tunnel path-mtu-discovery
!
interface Tunnel41
description HECnet GRE tunnel to Area 41 Paul Koning Dynamic DNS akdesign.dyndns.org paulkoning@comcast.net
no ip address
logging event subif-link-status
decnet cost 5
decnet hello-timer 90
decnet routing-timer 120
tunnel source FastEthernet0/1
tunnel destination 73.60.223.101
tunnel path-mtu-discovery
!
interface Tunnel42
description HECnet tunnel for Ian McLaughlin (Area 42)
no ip address
logging event subif-link-status
decnet cost 6
tunnel source FastEthernet0/1
tunnel destination 208.73.57.126
tunnel path-mtu-discovery
!
interface Tunnel52
no ip address
logging event subif-link-status
decnet cost 5
tunnel source FastEthernet0/1
tunnel destination 24.98.27.217
tunnel path-mtu-discovery
!
interface Tunnel59
description HECnet GRE Tunnel to 59.1020 Peter Lothberg <roll@stupi.com>
no ip address
logging event subif-link-status
decnet cost 7
decnet hello-timer 60
decnet routing-timer 90
tunnel source FastEthernet0/1
tunnel destination 192.108.197.26
tunnel path-mtu-discovery
!
interface Tunnel61
description HECnet tunnel for Dave McGuire (Area 61)
no ip address
logging event subif-link-status
decnet cost 5
tunnel source FastEthernet0/1
tunnel destination 50.73.179.1
tunnel path-mtu-discovery
!
interface Tunnel592
description HECnet GRE Area 59 2nd Tunnel Sweden Peter Lothberg <roll@stupi.com>
no ip address
logging event subif-link-status
decnet cost 8
decnet hello-timer 60
decnet routing-timer 90
tunnel source FastEthernet0/1
tunnel destination 192.108.200.213
tunnel path-mtu-discovery
!
interface FastEthernet0/0
no ip address
duplex half
speed auto
appletalk cable-range 10422-10422 10422.169
appletalk zone SANYALnet
decnet cost 4
decnet routing-timer 20
decnet router-priority 40
no mop enabled
!
interface FastEthernet0/1
ip address 10.42.3.4 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
no ip address
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
!
ip default-gateway 10.42.3.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.42.3.1
!
no ip http server
no ip http secure-server
!
!
logging trap debugging
logging 10.42.2.1
logging host 142.47.102.100 transport udp port 55514
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
snmp-server community decnet4ever RW
!
appletalk ignore-verify-errors
appletalk local-routing
appletalk permit-partial-zones
appletalk name-lookup-interval 15
appletalk zip-query-interval 30
decnet host IMPRTR 31.1023
decnet host PYRTR 31.3
decnet host PYDNET 31.1021
decnet host MOKSHA 31.1020
decnet host TSVMST 31.151
decnet host TSVMSA 31.150
decnet host MOSHML 31.149
decnet host IBM390 31.60
decnet host SHAKTI 31.50
decnet host NJEVX2 31.36
decnet host NJEVX1 31.35
decnet host NANAJU 31.34
decnet host XL 31.33
decnet host PIPY 31.32
decnet host XLIV 31.31
decnet host VAXSTN 31.30
decnet host TWENEX 31.29
decnet host RST101 31.28
decnet host MACOS7 31.27
decnet host W2000S 31.26
decnet host TSTVAX 31.24
decnet host XLVII 31.23
decnet host TRU64 31.22
decnet host WXPEE2 31.21
decnet host WFW311 31.20
decnet host MACOS9 31.19
decnet host RAPTOR 31.18
decnet host ENTEE4 31.17
decnet host WEXPEE 31.16
decnet host OSTARA 31.15
decnet host FOMFOR 31.14
decnet host FEDACH 31.13
decnet host JUICHI 31.12
decnet host CLOUDY 31.11
decnet host QCOCAL 31.10
decnet host IMPVAX 31.1
decnet host PYTHON 41.1
decnet host R29GW 59.56
decnet host KETURA 31.141
decnet host A61RTR 61.1023
decnet host A35RTR 35.1023
decnet host A34RTR 34.1023
decnet host A22RTR 22.1023
decnet host ODEN 59.1
decnet host HUB 42.1022
decnet host A12RTR 12.1023
decnet host R29GWA 59.60
decnet host KNARF 31.104
decnet host SUBWAY 31.100
decnet host MAKOTO 31.120
decnet host LARRY 31.130
decnet host FERRETRI 47.113
decnet host LOKI 2.150
decnet host SELENE 2.201
decnet host LEXX 2.300
decnet host DREAM 2.301
decnet host BEE 2.302
decnet host NJCVAX 2.400
decnet host MAGICA 1.1
decnet host ERNIE 1.2
decnet host FNATTE 1.3
decnet host GOBLIN 1.4
decnet host ZEKE 1.5
decnet host GNOME 1.6
decnet host BJARNE 1.7
decnet host KRILLE 1.8
decnet host TEMPO 1.9
decnet host SIGGE 1.10
decnet host ROCKY 1.11
decnet host PONY 1.12
decnet host MIM 1.13
decnet host TINA 1.14
decnet host PONDUS 1.15
decnet host GNAT 1.16
decnet host JOSSE 1.17
decnet host PAMINA 1.18
decnet host BEA 1.19
decnet host WXP 1.20
decnet host JOCKE 1.21
decnet host PUFF 1.22
decnet host WXP2 1.23
decnet host SPEEDY 1.24
decnet host FLETCH 1.100
decnet host HORSE 1.150
decnet host QEMUNT 1.151
decnet host PLINTH 1.200
decnet host CRISPS 1.201
decnet host NIPPER 1.202
decnet host TARDIS 1.250
decnet host MASTER 1.251
decnet host DOCTOR 1.252
decnet host SIDRAT 1.253
decnet host DAVROS 1.254
decnet host RUTAN 1.255
decnet host VAROS 1.256
decnet host THOROS 1.257
decnet host MACRA 1.258
decnet host CYGNUS 1.259
decnet host SHARPE 1.260
decnet host HARPER 1.261
decnet host HAGMAN 1.262
decnet host COOPER 1.263
decnet host TONGUE 1.264
decnet host PACMAN 1.265
decnet host BLINKY 1.266
decnet host PINKY 1.267
decnet host INKY 1.268
decnet host CLYDE 1.269
decnet host ORAV23 1.301
decnet host ORAV41 1.302
decnet host RSX134 1.303
decnet host RSX145 1.304
decnet host RSX170 1.305
decnet host RSX124 1.306
decnet host RSX184 1.307
decnet host ERSATZ 1.350
decnet host DBIT 1.351
decnet host VALAR 1.400
decnet host DE1RSX 1.450
decnet host KLIO 1.451
decnet host DE1RSY 1.452
decnet host HYUNA 1.500
decnet host JIMIN 1.501
decnet host PMAVS2 1.510
decnet host PISTON 1.520
decnet host REI 1.540
decnet host PAI 1.541
decnet host ROJIN 1.542
decnet host PIDP11 1.560
decnet host TOPSY 1.601
decnet host HUGIN 1.602
decnet host MUNIN 1.603
decnet host TIPSY 1.604
decnet host ATLE 1.605
decnet host AURORA 1.606
decnet host LOKE 1.607
decnet host FREJ 1.608
decnet host YMER 1.609
decnet host NOMAD 1.610
decnet host ELIN 1.616
decnet host ELMER 1.617
decnet host ATHENA 1.620
decnet host PALLAS 1.621
decnet host NOXBIT 1.720
decnet host GAXP 1.730
decnet host GVAX 1.731
decnet host BANAI 1.770
decnet host BANDEV 1.771
decnet host BIZET 1.800
decnet host A1RTR 1.1023
decnet host LEGATO 2.1
decnet host POCO 2.2
decnet host MEZZO 2.4
decnet host LARGO 2.6
decnet host CODA 2.7
decnet host DIVISI 2.9
decnet host ADAGIO 2.10
decnet host LENTO 2.11
decnet host JENSEN 2.12
decnet host MULTIA 2.14
decnet host PAVANE 2.15
decnet host ZITI 2.16
decnet host CHARON 2.17
decnet host VENTI 2.20
decnet host APOLLO 2.400
decnet host CYPHER 2.401
decnet host MENTOR 2.402
decnet host CONDOR 2.403
decnet host TOMMYT 2.520
decnet host VENTI2 2.522
decnet host A2RTR 2.1023
decnet host RVDSXL 3.47
decnet host NUK1C 3.171
decnet host MUSIPC 3.222
decnet host B7 4.1
decnet host HALO 4.2
decnet host DALLAS 4.10
decnet host RIPLEY 4.11
decnet host TSR2 4.12
decnet host VULCAN 4.13
decnet host VICTOR 4.14
decnet host CALPHA 4.244
decnet host ENGINE 4.245
decnet host MOTHER 4.246
decnet host MINERV 4.247
decnet host SIMVAX 4.248
decnet host SLAVE 4.249
decnet host ORAC 4.250
decnet host ZX6000 4.251
decnet host NODE3 4.252
decnet host NODE2 4.253
decnet host X60 4.255
decnet host BUBBLE 4.256
decnet host ELLEN 4.257
decnet host TIGER 4.258
decnet host ALEPH 4.259
decnet host VLC1 5.2
decnet host VAX780 5.8
decnet host MICRO1 5.10
decnet host MAINVX 5.11
decnet host MICRO2 5.12
decnet host VAX4 5.14
decnet host VAX6 5.20
decnet host VAX7 5.21
decnet host MICRO4 5.24
decnet host RTVAX 5.30
decnet host DAGO 5.101
decnet host FRANZ 5.102
decnet host DANIEL 5.103
decnet host DONALD 5.104
decnet host TRACK 5.105
decnet host TRICK 5.106
decnet host DAISY 5.107
decnet host GUNDEL 5.108
decnet host GITTA 5.109
decnet host PANZER 5.110
decnet host PRIMUS 5.111
decnet host GUSTAV 5.112
decnet host DORETT 5.113
decnet host HELFER 5.114
decnet host DICKY 5.115
decnet host KUNO 5.116
decnet host KLAAS 5.117
decnet host RITA 5.118
decnet host HOMER 5.130
decnet host MAGGIE 5.132
decnet host EARL 5.201
decnet host FRAN 5.202
decnet host ROBBIE 5.203
decnet host CHARLY 5.204
decnet host BRUCE 5.205
decnet host ETHYL 5.206
decnet host ROY 5.207
decnet host BASIL 5.208
decnet host SPIKE 5.209
decnet host MONICA 5.210
decnet host MARIO 5.211
decnet host JAKA 5.301
decnet host LILI 5.302
decnet host JULIUS 5.303
decnet host A5RTR 5.1023
decnet host STAR69 6.1
decnet host QUIGON 6.2
decnet host BARTLD 6.3
decnet host TOOCHI 6.4
decnet host DARMOK 6.51
decnet host JALAD 6.52
decnet host ARTHUR 6.110
decnet host MARSHA 6.130
decnet host ROOSTA 6.134
decnet host MBSERV 7.6
decnet host BITXOV 7.60
decnet host BITXOO 7.61
decnet host BITXO1 7.64
decnet host BITXO2 7.65
decnet host BITXOS 7.66
decnet host BITXO4 7.67
decnet host BITXO5 7.68
decnet host BITXOT 7.70
decnet host BITXOR 7.71
decnet host BITXOM 7.72
decnet host BITXOW 7.74
decnet host BITXOX 7.76
decnet host BITXT2 7.78
decnet host BITXT0 7.79
decnet host BITXT1 7.80
decnet host BITXOZ 7.81
decnet host BITXOU 7.82
decnet host PPVX01 8.100
decnet host PPVX02 8.101
decnet host PPVX03 8.102
decnet host TACO 8.200
decnet host HIRAME 8.201
decnet host INARI 8.202
decnet host HAMACH 8.203
decnet host SUZUKI 8.204
decnet host EBISU 8.205
decnet host UNAGI 8.207
decnet host MAGURO 8.210
decnet host BEIRUT 8.220
decnet host LBNVAX 8.221
decnet host KIBBEH 8.222
decnet host WATAN 8.223
decnet host LABNEH 8.224
decnet host JBEIL 8.225
decnet host RMEIL 8.226
decnet host RESCUE 8.244
decnet host GORVAX 8.400
decnet host CHIMPY 8.401
decnet host CHIMP 8.402
decnet host RHESUS 8.403
decnet host SAMDEV 8.404
decnet host ARIVAX 8.405
decnet host VAXPLS 8.408
decnet host FIDOGW 8.410
decnet host SOLAR 8.414
decnet host LUNAR 8.415
decnet host LEMUR 8.430
decnet host B4GATE 8.444
decnet host PYFFLE 8.500
decnet host RAZZLE 8.700
decnet host BONZO 8.800
decnet host DELLVX 8.808
decnet host SMDEV0 8.900
decnet host SMDEV1 8.901
decnet host SMDEV2 8.902
decnet host SMDEV3 8.903
decnet host MOIRA 9.1
decnet host MINDY 9.2
decnet host MISSY 9.3
decnet host MANDY 9.4
decnet host GEWTST 9.5
decnet host GEWT1 9.7
decnet host MARLEY 9.10
decnet host MOYA 9.12
decnet host A9RTR2 9.1022
decnet host A9RTR1 9.1023
decnet host SHARK 10.1
decnet host SNAKE 10.2
decnet host VAXSYS 11.1
decnet host MAISA 11.2
decnet host A11PI 11.3
decnet host SORKKA 11.4
decnet host VS3K1 11.5
decnet host VSVLC 11.6
decnet host HAWK 11.7
decnet host EAGLE 11.8
decnet host JYLKM5 11.9
decnet host VS2K1 11.10
decnet host VS4K5 11.11
decnet host VS2K3 11.12
decnet host VS2K4 11.13
decnet host UGLY 11.14
decnet host CUTE 11.15
decnet host MOPO 11.16
decnet host ROMU 11.17
decnet host VS3K2 11.18
decnet host PAKVXT 11.20
decnet host DS20 11.100
decnet host AXPSYS 11.101
decnet host ALPHA 11.102
decnet host GAMMA 11.103
decnet host DELTA 11.104
decnet host BETA 11.105
decnet host A11RTR 11.1023
decnet host DOCMST 12.1
decnet host BENDER 12.2
decnet host TRON 12.3
decnet host POOKY 12.4
decnet host BLACK 13.1
decnet host BROWN 13.2
decnet host RED 13.3
decnet host ORANGE 13.4
decnet host YELLOW 13.5
decnet host GREEN 13.6
decnet host BLUE 13.7
decnet host VIOLET 13.8
decnet host GREY 13.9
decnet host WHITE 13.10
decnet host COLORS 13.1023
decnet host SKNLIN 14.1
decnet host SKNRSX 14.2
decnet host SKNRSE 14.3
decnet host SKHNGW 14.4
decnet host SKNRX5 14.5
decnet host BLISH 17.101
decnet host GORDON 17.102
decnet host VERNE 17.221
decnet host KNIGHT 17.1023
decnet host VEGAS 18.100
decnet host RENO 18.101
decnet host MINDEN 18.102
decnet host NYE 18.103
decnet host FALLON 18.104
decnet host EYN 18.105
decnet host ELKO 18.150
decnet host ELY 18.151
decnet host SULLY 18.414
decnet host FLIND 18.777
decnet host GATE18 18.1023
decnet host STRGTE 19.4
decnet host AGENA 19.11
decnet host ALTAIR 19.12
decnet host CRUCIS 19.13
decnet host TAURI 19.14
decnet host SCORPI 19.15
decnet host SPICA 19.16
decnet host POLLUX 19.17
decnet host PISCIS 19.18
decnet host DENUB 19.19
decnet host PLUTO 19.23
decnet host LUNA 19.38
decnet host SGC 19.40
decnet host SG1 19.41
decnet host SG2 19.42
decnet host SG3 19.43
decnet host SG4 19.44
decnet host SG5 19.45
decnet host SG6 19.46
decnet host SG7 19.47
decnet host SG8 19.48
decnet host SG9 19.49
decnet host VENUS 19.55
decnet host STARS 19.77
decnet host CERES 19.82
decnet host MARS 19.83
decnet host DWARF 19.140
decnet host DWARF1 19.141
decnet host DWARF2 19.142
decnet host DWARF3 19.143
decnet host DWARF4 19.144
decnet host DWARF5 19.145
decnet host DWARF6 19.146
decnet host DWARF7 19.147
decnet host GALAXY 19.150
decnet host HELIOS 19.151
decnet host SIRIUS 19.152
decnet host ORION 19.153
decnet host SATURN 19.155
decnet host RPIPDP 19.216
decnet host RPIVAX 19.224
decnet host DECVAX 19.253
decnet host DECLAB 19.254
decnet host URANUS 19.255
decnet host ISIS 19.511
decnet host KRONOS 19.512
decnet host EOS 19.513
decnet host ATLAS 19.514
decnet host HYDRA 19.515
decnet host DAEMON 19.666
decnet host BLKHOL 19.1023
decnet host WOPR 20.1
decnet host SIOP 20.2
decnet host TX0 20.3
decnet host JOSHUA 20.4
decnet host FALKEN 20.5
decnet host LYTMAN 20.6
decnet host NORAD 20.100
decnet host SNOW 20.513
decnet host SNIFFY 22.10
decnet host SNOTTY 22.11
decnet host SNORTR 22.12
decnet host KVASIR 22.13
decnet host OLAF 22.14
decnet host ODIN 22.15
decnet host THOR 22.16
decnet host SNOTRA 22.17
decnet host ULLR 22.18
decnet host LOFN 22.19
decnet host GRUMPY 22.20
decnet host DOPEY 22.21
decnet host SNEEZY 22.22
decnet host SLEEPY 22.23
decnet host HAPPY 22.24
decnet host BSHFUL 22.25
decnet host DOCK 22.26
decnet host HEIGH 22.27
decnet host HO 22.28
decnet host RAVEN 22.29
decnet host DWARFS 22.30
decnet host THANOS 22.31
decnet host BALDUR 22.32
decnet host TYR 22.33
decnet host SKAGI 22.34
decnet host BORR 22.35
decnet host DAGUR 22.36
decnet host NOTT 22.37
decnet host HEL 22.38
decnet host PIGLET 23.1
decnet host RABBIT 23.2
decnet host OWL 23.3
decnet host ROO 23.4
decnet host MEGARA 24.1
decnet host DEUS 24.2
decnet host MIRAGE 24.3
decnet host LINC 24.4
decnet host EVE 24.5
decnet host VAAL 24.6
decnet host HEX 24.7
decnet host SARAH 24.8
decnet host MARA 24.20
decnet host DURNDL 24.21
decnet host LEELA 24.22
decnet host TYCHO 24.23
decnet host TRAXUS 24.24
decnet host THOTH 24.25
decnet host FROST 24.1023
decnet host MEDDLE 25.29
decnet host AGAR30 25.30
decnet host SPRI31 25.31
decnet host DOUDOU 26.114
decnet host VIDOU 26.115
decnet host MERKUR 26.201
decnet host TGE411 26.411
decnet host AREA27 27.1
decnet host ALDUR 27.4
decnet host ALDUR2 27.5
decnet host RULCRI 28.1
decnet host RULLFR 28.3
decnet host RULLFL 28.4
decnet host RULLF2 28.5
decnet host CUTLER 28.8
decnet host MSTG84 28.9
decnet host RULLF 28.26
decnet host RULLFS 28.41
decnet host A29RT1 29.1
decnet host A29RT2 29.2
decnet host DUNE 29.100
decnet host IX 29.101
decnet host CALADN 29.102
decnet host KAITN 29.103
decnet host ROSSAK 29.104
decnet host ARAKIS 29.105
decnet host SALUSA 29.106
decnet host ANBUS 29.107
decnet host WALACH 29.108
decnet host TUPILE 29.109
decnet host TLEILX 29.110
decnet host PIVAX0 29.200
decnet host PIVAX1 29.201
decnet host PIVAX2 29.202
decnet host PIVAX3 29.203
decnet host PIVAX4 29.204
decnet host PIRSTS 29.205
decnet host ONAPI4 29.206
decnet host VMS046 29.207
decnet host PIRTVX 29.208
decnet host PIVAXN 29.209
decnet host FRODO 30.1
decnet host MV80 30.2
decnet host RD73 30.3
decnet host YODA 30.4
decnet host IMAC 30.5
decnet host RD83 30.6
decnet host LTC 30.7
decnet host LAN40 30.10
decnet host RDP1 30.11
decnet host RDP2 30.12
decnet host CBVRP3 30.15
decnet host KARMA 31.2
decnet host BMT 31.101
decnet host IRT 31.102
decnet host IND 31.103
decnet host MOE 31.131
decnet host CURLY 31.132
decnet host MOSHIX 31.140
decnet host FDR 32.1
decnet host THRIFT 33.1
decnet host CHARY 33.4
decnet host FRUGAL 33.14
decnet host MISER 33.15
decnet host CHEAP 33.17
decnet host FOOVAX 34.100
decnet host FORGER 34.101
decnet host BBTVAX 34.102
decnet host FARGO 34.200
decnet host FULBCK 34.201
decnet host SHIVA 34.1022
decnet host THOMAS 35.70
decnet host HENRY 35.71
decnet host WIZVAX 35.91
decnet host MASON 39.1
decnet host ROXY 39.10
decnet host BOSCO 39.11
decnet host NI1D 41.2
decnet host PYTS41 41.41
decnet host CANADA 42.1
decnet host DAFFY 42.2
decnet host FUZZY 42.3
decnet host RIVEN 42.4
decnet host SPARKY 42.5
decnet host EARTH 42.6
decnet host MOON 42.7
decnet host FRICK 42.8
decnet host FRACK 42.9
decnet host BOB 42.10
decnet host DOUG 42.11
decnet host BET 42.42
decnet host A42RTR 42.1023
decnet host HVITA 43.43
decnet host HEKLA 43.44
decnet host HELIUM 44.1
decnet host XENON 44.2
decnet host ARGON 44.3
decnet host NEON 44.4
decnet host ZILVER 44.5
decnet host JODIUM 44.6
decnet host RADON 44.7
decnet host ASTAAT 44.8
decnet host OSMIUM 44.9
decnet host CHLOOR 44.10
decnet host ZWAWEL 44.11
decnet host INDIUM 44.12
decnet host ERBIUM 44.13
decnet host BROOM 44.14
decnet host FOSFOR 44.15
decnet host COBALT 44.16
decnet host KOPER 44.17
decnet host CERIUM 44.18
decnet host IJZER 44.19
decnet host CHROOM 44.20
decnet host NIKKEL 44.21
decnet host ZINK 44.22
decnet host LOOD 44.23
decnet host CURIUM 44.24
decnet host KWIK 44.25
decnet host GOUD 44.26
decnet host RADIUM 44.27
decnet host TIN 44.28
decnet host FLUOR 44.29
decnet host BOOR 44.30
decnet host SELEEN 44.31
decnet host ARSEEN 44.32
decnet host CARBON 44.33
decnet host OXYGEN 44.34
decnet host TITAAN 44.35
decnet host URAAN 44.36
decnet host BARIUM 44.37
decnet host CESIUM 44.38
decnet host KALIUM 44.39
decnet host AZOTE 44.41
decnet host VISMUT 44.42
decnet host OZON 44.43
decnet host RODIUM 44.46
decnet host A44RTR 44.1023
decnet host ZZYZZX 46.1
decnet host TCNVAX 46.2
decnet host AVOCET 46.5
decnet host BADGER 46.6
decnet host CURLEW 46.7
decnet host DONKEY 46.8
decnet host ERMINE 46.9
decnet host FERRET 46.10
decnet host GIFTVX 47.11
decnet host GFTVX2 47.12
decnet host RFSAXP 47.47
decnet host HILANT 47.100
decnet host SIIRI 47.113
decnet host BEEFY 47.333
decnet host LABVAX 47.555
decnet host KUHAVX 47.556
decnet host HPIVAX 47.559
decnet host SOLAR5 47.661
decnet host K4VX1 47.700
decnet host K4VX2 47.701
decnet host SHAMS 47.727
decnet host QAMAR 47.747
decnet host K90VX1 47.800
decnet host K90VX2 47.801
decnet host RNDVAX 47.900
decnet host BONZO2 47.1000
decnet host SIIKA 47.1001
decnet host SIIKAX 47.1002
decnet host SLIMER 51.1
decnet host WALTER 51.2
decnet host DANA 51.3
decnet host GOZER 51.4
decnet host RAY 51.5
decnet host VIGO 51.6
decnet host LENNY 51.7
decnet host GHOST 51.10
decnet host SUN 52.1
decnet host RIFTER 52.2
decnet host VIGIL 52.3
decnet host DRAKE 52.4
decnet host VARGUR 52.11
decnet host GOLEM 52.12
decnet host DEB390 52.600
decnet host A52RTR 52.1023
decnet host CHEKOV 54.27
decnet host GEORDI 54.28
decnet host CEIRE 54.59
decnet host SPOCK 54.66
decnet host CEIDE 54.80
decnet host CEISI 54.81
decnet host CEIEE 54.82
decnet host SCOTTY 54.92
decnet host A54RTR 54.100
decnet host BTP 54.188
decnet host NEWACA 54.203
decnet host BOFIN 54.334
decnet host SWBV55 55.55
decnet host NADJA 59.7
decnet host SOL 59.10
decnet host DIMMA 59.11
decnet host XERXES 59.16
decnet host KLEO 59.18
decnet host KLAS 59.19
decnet host KICKI 59.20
decnet host STORM 59.23
decnet host TOAD1 59.30
decnet host ULLA 59.31
decnet host FORNAX 59.32
decnet host REGN 59.33
decnet host VERA 59.40
decnet host MRC 59.41
decnet host ELVIRA 59.53
decnet host KRYLBO 59.55
decnet host E825GW 59.57
decnet host STUPI 59.58
decnet host OPS1VA 59.59
decnet host CAMECA 60.648
decnet host ZEUS 60.649
decnet host SAVAGE 60.650
decnet host JOHNNY 60.651
decnet host MONK 60.652
decnet host HAM 60.653
decnet host DOC 60.654
decnet host RENNY 60.660
decnet host LNGTOM 60.661
decnet host DS201 60.662
decnet host RSTSE 60.663
decnet host PDXVAX 60.664
decnet host AXPEE 61.2
decnet host EBOLA 61.3
decnet host MECCA 61.4
decnet host FANG 61.5
decnet host BIGV7K 61.6
decnet host RA 61.50
decnet host GLGMSH 61.150
decnet host MARDUK 61.151
decnet host ENKIDU 61.152
decnet host CTEPBA 62.1
decnet host XPEH 62.2
decnet host BIGSYS 62.3
decnet host COPOKA 62.4
decnet host BOPOHA 62.5
decnet host KOPOBA 62.6
decnet host TIS 62.7
decnet host ASDS20 62.8
decnet host ASGS80 62.9
decnet host NOKIA 62.10
decnet host KYPEBO 62.11
decnet host CTEPEO 62.12
decnet host MOHO 62.13
decnet host CM1420 62.14
decnet host CAXAP 62.15
decnet host BETEP 62.16
decnet host CCCP 62.17
decnet host CTAKAH 62.637
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password <redacted>
login
!
ntp clock-period 17179934
ntp master
ntp server 132.163.97.3
ntp server 132.163.97.2
ntp server 132.163.97.4
ntp server 162.248.164.73
ntp server 129.6.15.30
ntp server 129.6.15.29
ntp server 162.248.164.118
ntp server 129.6.15.27
!
end





Recommended Products from Amazon